RMA Status : Check-Out

Your Shipping Address:

Name : Jamie Avanecean
Email : net_master6@hotmail.com
Street Address : 20 Fremont st
City : Putnam
State : Ct
Zip Code : 06260
Country : USA
Phone : (860) 931-9133
Product To Return : MCL1001 MX540 4000KV
Problem With Product : Purchase new installed in new kyosho ultima sc6. Went to track ran two five minute practice laps then waited for the heats to start. Time came plugged in and motor would not turn, esc powered on I have steering control but yet the motor will not turn esc will not go into collaboration only shows power on colors and that’s it. Less than ten minutes on track and system is dead. It is geared 23/80 on 2s lipo did not get hot at all motor or esc and ran great while it worked.
Date Purchased : 2018-01-26
Where Purchased : Ebay


RMA: 860

HAD RMA ship to address:

Service Department
14754 NE 95th St.
Redmond, WA 98052
USA

Customer Copy:

Name : Jamie Avanecean
Email : net_master6@hotmail.com
Street Address : 20 Fremont st
City : Putnam
State : Ct
Zip Code : 06260
Country : USA
Phone : (860) 931-9133
Product To Return : MCL1001 MX540 4000KV
Problem With Product : Purchase new installed in new kyosho ultima sc6. Went to track ran two five minute practice laps then waited for the heats to start. Time came plugged in and motor would not turn, esc powered on I have steering control but yet the motor will not turn esc will not go into collaboration only shows power on colors and that’s it. Less than ten minutes on track and system is dead. It is geared 23/80 on 2s lipo did not get hot at all motor or esc and ran great while it worked.
Date Purchased : 2018-01-26
Where Purchased : Ebay


RMA: 860

« Click here to return to the home page

User Note

  • The ESC was found to have corrupted firmware.
  • Flashed the firmware to version A1.9, test OK.
  • See RMA860 testing video.

Check-out: 2/20/2018 Shipped via US Mail with tracking number:  9400111699000992476135