RMA Status : Check-Out

Your Shipping Address:

Name : Dana Osborn
Email : danarosborn@gmail.com
Street Address : 2145 Grist Mill Dr. SW
City : Concord
State : North Carolina
Zip Code : 28025
Country : United States
Phone : (510) 299-7572
Product To Return : MCL2003 MMax Pro 160A ESC
Problem With Product : The ESC stopped working this weekend. At first I assumed it was the voltage cutoff but after changing the battery it would still not turn the motor. Spent time looking for damage or an obvious issue but I could not find one. Turned everything off and un-plugged and re-plugged everything in and still no go. The blinking trouble codes on the ESC kept changing every time I turned it off and on. After 30-45 mins of trying to trouble shoot the issue the lights now seem to give me the same code all the time Red and blue flash together that indicates no receiver signal. But the servo still works when I turn the wheel on the transmitter, and I also tried another receiver with still same issue. Also both the fan on the ESC and the servo now act twitchy when nothing is happening. This was purchased just over a month ago any only has approx. 5-6 battery packs run through the unit. Very disappointed. Please let me know what over items I need to provide to have this fixed or replaced.
Date Purchased : 2020-08-30
Where Purchased : A Main Hobbies


RMA: 1547

HAD RMA ship to address:

Service Department
14754 NE 95th St.
Redmond, WA 98052
USA

Customer Copy:

Name : Dana Osborn
Email : danarosborn@gmail.com
Street Address : 2145 Grist Mill Dr. SW
City : Concord
State : North Carolina
Zip Code : 28025
Country : United States
Phone : (510) 299-7572
Product To Return : MCL2003 MMax Pro 160A ESC
Problem With Product : The ESC stopped working this weekend. At first I assumed it was the voltage cutoff but after changing the battery it would still not turn the motor. Spent time looking for damage or an obvious issue but I could not find one. Turned everything off and un-plugged and re-plugged everything in and still no go. The blinking trouble codes on the ESC kept changing every time I turned it off and on. After 30-45 mins of trying to trouble shoot the issue the lights now seem to give me the same code all the time Red and blue flash together that indicates no receiver signal. But the servo still works when I turn the wheel on the transmitter, and I also tried another receiver with still same issue. Also both the fan on the ESC and the servo now act twitchy when nothing is happening. This was purchased just over a month ago any only has approx. 5-6 battery packs run through the unit. Very disappointed. Please let me know what over items I need to provide to have this fixed or replaced.
Date Purchased : 2020-08-30
Where Purchased : A Main Hobbies


RMA: 1547

« Click here to return to the home page

User Note

Check-in: 10/14/2020 3:2PM.

Inspection: 10/16/2020

  • Checked ESC data logging, the last session in the data logging shows voltage started low at 7.1V. The session ran for 5 minutes and dropped as low as 5.8V. Please see the below da logging screenshots.

 

  • Photo 1: Session started at very low voltage at 7.1V
  • Photo 2: At 5 mins mark the voltage dropped to 6.1V, the low voltage cut off kicked in
  • Photo 3: At a point the voltage dropped to 5.8V, possibly by the servo and cooling fan

 

  • We tested and verified the ESC and cooling fan with no problem found, please see RMA1547 testing video.
  • We will waive the no return shipping $8 in this case.¬†Please let us know if you have any question before we ship this ESC back.

Check out: 11/2/2020, ship via USPS#9400111202555267896067.